However, it is also possible that conflicting dependencies exist such that they are impossible to satisfy simultaneously.

If such a conflict exists in the dependencies of two different packages, then those packages can not be installed simultaneously. One of the following masked packages is required to complete your request: - dev-python/urllib3-1.14::gentoo (masked by: EAPI 6) - dev-python/urllib3-1.13.1-r1::gentoo (masked by: EAPI 6) The current version of portage supports EAPI '5'. ,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-)] (=dev-lang/python-exec-2:=[python_targets_python2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-)]) required by (dev-python/ipaddress-1.0.15:0/0::gentoo, installed) =dev-lang/python-exec-2:=[python_targets_pypy(-)?

etc portage package unmask needs updating-40

If the installed version is newer than the keyworded version, or is not longer installed at all, the keyword is considered obsolete.

If the installed package is the same version as the keyworded version then the installed package is checked to see if it is still keyworded.

A Shell is a command line interface or terminal, known to MS Windows users as The Command Prompt. Short Answer: In a root shell type emerge packagename where packagename is the name of the package you wish to install.

Technically, the Shell is actually the environment of the command line and not just the front-end for it. Alt-F2 is the global shortcut for this (it works in KDE, Gnome, XFCE, etc); it can also be accessed by right-clicking on the Desktop and selecting Run Command from the menu. Finally, the EASIEST and BEST method for Sabayon or Gentoo is using Portage / emerge.

To get into a Root Shell either use the su (switch user) command by typing su - (the "-" means change to that user's settings and home directory) or press Alt-F2 and type kdesu shellprogram or gnomesu shellprogram where shellprogram is "konsole", "gnome-terminal", "xterm" (without the quotes) or another. The most useful toolbar known to new Sabayon users is the Run Command Dialog, which allows you to run all sorts of programs and commands simply by typing the name of the command and pressing Enter. GENERALLY YOU WILL WANT TO IGNORE THE FIRST METHOD BELOW!!! For specific examples or command line examples with all the correct options for each step use Google :), or your brain.

To get to a Shell, press Alt-F2 (the shortcut key for the Run command window) and type konsole or gnome-terminal or xterm depending on your preference. Because it is an easy way for issuing multiple commands on one line. Longer answer: This depends on what method you are using or what software you want to install.You may want to try a larger value of the --backtrack option, such as --backtrack=30, in order to see if that will solve this conflict automatically. ,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]" have been masked. You must upgrade to a newer version of portage before EAPI masked packages can be installed. ,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] (=dev-lang/python-exec-2:=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]) required by (dev-python/ssl-fetch-0.3:0/0::gentoo, installed) =dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed) =dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_pypy(-),-python_single_target_pypy3(-)] required by (dev-python/py-1.4.30:0/0::gentoo, installed) =dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (sys-apps/kmod-19:0/0::gentoo, installed) =dev-lang/python-exec-2:=[python_targets_pypy(-)? For more information, see MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. (dependency required by "dev-python/requests-2.9.1-r2::gentoo" [ebuild]) (dependency required by "dev-python/ssl-fetch-0.4::gentoo" [ebuild]) (dependency required by "app-portage/layman-2.3.0-r1::gentoo" [ebuild]) (dependency required by "@selected" [set]) (dependency required by "@world" [argument]) For more information, see the MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. funtoo rj # emerge -pv gentoolkit portage These are the packages that would be merged, in order: Calculating dependencies... [ebuild R ] sys-apps/portage-2.4.1::gentoo USE="(ipc) xattr -build -doc -epydoc (-selinux)" LINGUAS="-ru" PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_3 -python3_5" 0 Ki B [ebuild R ] app-portage/gentoolkit-0.3.1::gentoo PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_3 -python3_5" 0 Ki B Total: 2 packages (2 reinstalls), Size of downloads: 0 Ki B These are the packages that would be merged, in order: Calculating dependencies... into the dependency graph, resulting in a slot conflict: dev-libs/icu:0 (dev-libs/icu-56.1:0/56::gentoo, ebuild scheduled for merge) pulled in by (no parents that aren't satisfied by other packages in this slot) (dev-libs/icu-55.1:0/55::gentoo, installed) pulled in by dev-libs/icu:0/55=[abi_x86_32(-),abi_x86_64(-)] required by (dev-qt/qtcore-4.8.7-r1:4/4::gentoo, installed) ^^^^^^ It may be possible to solve this problem by using to prevent one of those packages from being selected. ,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] (=dev-lang/python-exec-2:=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)]) required by (sys-apps/portage-2.4.0:0/0::gentoo, installed) =dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_pypy(-)] required by (dev-python/ssl-fetch-0.3:0/0::gentoo, installed) =dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_pypy(-),-python_single_target_pypy3(-)] required by (dev-python/idna-2.0:0/0::gentoo, installed) =dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_pypy(-),-python_single_target_pypy3(-)] required by (virtual/python-ipaddress-1.0:0/0::gentoo, installed) =dev-lang/python-exec-2:=[python_targets_python2_7(-)? Multiple package instances within a single package slot have been pulled !!! ,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] (=dev-lang/python-exec-2:=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)]) required by (app-editors/vim-7.4.712:0/0::gentoo, installed) dev-lang/python-exec:2 required by (dev-python/pygobject-2.28.6-r55:2/2::gentoo, installed) =dev-lang/python-exec-2:=[python_targets_pypy(-)? The masked packages are available to give you the freedom to choose between the latest development versions and the stable branches.